Vauxhall Zafira Forum banner
Club Information

Club Discounts

Club Discounts - 20 posts required to view
28
14.1K
28
14.1K
General Message Area

Newbies

Introduce yourself here......
9.5K
4.7M
9.5K
4.7M

General Discussion Area

Anything Zafira related.
2.7K
1.8M
2.7K
1.8M

The Good and the Bad..!!

Post up your experiences of owning your Zafira
224
265K
224
265K

Spotted

Spotted a fellow Zaffers?
131
56.3K
131
56.3K

Gallery

Show off your Zafira pictures here
520
233K
520
233K
Zafira 2005 - 2011

General

General topics on Zafira
2.3K
2.7M
2.3K
2.7M

Technical

Faults and technical problems
7.5K
7.1M
7.5K
7.1M

Modifications

Modding the Zafira
603
542K
603
542K
Zafira 1999 to 2005

General

General topics on Zafira
1.4K
1M
1.4K
1M

Technical

Faults and technical problems
5.3K
5M
5.3K
5M

Modifications

Modding the Zafira
385
311K
385
311K
Zafira VXR

General

Forum for the Zafira VXR
26
30.1K
26
30.1K
Zafira Tourer 2012

Zafira Tourer

General forum for the new Zafira Tourer
1.5K
1.3M
1.5K
1.3M

Zafira Tourer Ordering

Ordering and Delivery forum for the 2012 Zafira Tourer
67
25.5K
67
25.5K
Classifieds

For Sale & Wanted

Sell & buy Zafira related items
800
376K
800
376K
Vendor Member Section Want to Grow Your Business? Learn more about becoming a Supporting or Premium Vendor

Vendor Deals

1
1.2K
1
1.2K
Forum Support
Latest Posts See all new posts
  1. Good afternoon, brought the above vehicle a few days ago as a cheap family run around - it was advertised as having a small oil leak. After taking it for a diagnostic the garage has said it needs to replace the piston rings as they are on the way out. Symptoms we have are: Juddering while idle...
  2. Accurate or not, the ampermeter is showing 330 mA, when key is out and car is totally passive. This drains the battery "in a week". When fuse 28 is out, amperemeter indicates approx 10mA (could be inaccurate, but something around that level). Should be close to normal behavior then. I cannot...
  3. Can someone help please. I have a Zafira B. With all lights switched off, both rear N/S and O/S brake lights and the tail lights on all the time, with engine running or just ignition on. The car has no rear fuseboard, just a few fuses and relays near rear O/S light cluster. When brake pedal...
  4. Technical
    I have a Zafira 1.6 Reg June 2011 milage 72,306. Recently passed MOT with flying colours. However because a member of family has a bad back, would like to make the ride softer, in the passenger seat . Tried reducing tyre pressures slightly. Not much help. Has anyone encountered similar problems...
  5. Hi and thanks for adding me I have a problem with my zafira 2011 1.7 cdti ecoflex it has 99k I replaced the battery on my car as it went flat and now the power stearing has stopped working and the live batery terminal is getting hot I've checked all fuses and checked that the altinator wire is...
See all new posts
Top