Vauxhall Zafira Forum banner
1 - 1 of 1 Posts

4 Posts
Discussion Starter · #1 ·
Hi all, my brother is unfortunate enough to have bought a Zafira, he's had the head gasket done twice in two years. This week the AA were called for non starting. They got him mobile but advised on the injector seals. He broke down again and being his brother I had a look.
Yep, no fuel so bled it and replaced the leak off, what a sh!t design then cleaned the EGR, wasn't to dirty. Started fine. Took it for a drive and no temperature gauge movement, then dreaded service light then no dashboard movement of any needle, no speed, fuel, revs or mileage movement even after a five mile run.
Switchs off locks opens and starts fine but still no dash at all. I tried battery disconection for an hour and all fuses look good.
Has anyone got any ideas or experienced anything as bizzare as this before.
Of course first thoughts go to the ECU but it's running fine.
1 - 1 of 1 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.