Vauxhall Zafira Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hey lad
im new to the forum so bear with m
i have a 07 1.6 petrol Zafira
the heater blower isnt working and all fuses are o
any suggestions on how to fix it myself as im robbed from putting money into i
also the spanner light is on and its down in power occasionall
any help would be great lads
love the forum
 

·
Registered
Joined
·
1,498 Posts
Hi there Roy, and welcome to the Owner's Forum.
A common fault with Zafira's is the failure of the Resistor Pack that supplies the reduced power to the blower motor control in positions 1,2, and 3. Position 4 is fed direct so usually works, even when the others don't. Can you confirm that your position 4 is working..??

The resistor pack is fitted behind the glovebox above the main heater box. If you are going to fit a replacement pack, make sure that the blower motor itself is in good condition and turning freely. If it is sticking, it can overheat the resistor pack, which has been known in the past to get red hot and even, in a few cases, catch fire..!!

If none of the switch positions are working, and you are absolutely sure that your fuses are OK, then I would suspect that the blower motor itself has packed up. It could just be the carbon brushes have worn out and these can be easily fixed. Look on eBay for zafira Blower Motor Brushes. If the armature wiring has gone though, then its not worth bothering to try and repair it - get a replacement motor and fit it...
Best of luck.
Cheers.... Robin
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #4 ·
Hey robin
thanks so much 4 d reply so fast :)
I just checked it now and ffsake wud u believe it its workinh fine now ?
But it surely isnt normal and theres some under lying prob seems 2b intermittent
any ideas 4 the spanner light? s
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #7 ·
Marks152 heres the fault code thati i get 112052 ec
hope that help
cos the spanner light is still on
also the blower fan inside works intermittantly so again im los
any help appreciate
thanks so much :)
 

·
Registered
Joined
·
1 Posts
My Aircon made a terrible noise one day when I turned it on, like a horrible cranking noise or the noise you make when you put your finger on the edge of a fan blade. The aircon light was still able to be engaged and compressor was still working but no air was coming through any vent either on Aircon or without Aircon(just plain airflow), This told me the issue was with my blower or blower motor. so I stripped down the blower and this is what fell out. Removed the carcass and put everything back and now it works perfectly.
I also needed to put new air freshers in the car - the smell was HORRENDOUS. One of the hazzards of living in a rural setting in Spain
Automotive tire Motor vehicle Tire Hood Automotive lighting
 
1 - 8 of 8 Posts
Top