Vauxhall Zafira Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi can someone advise
I have 04zafira 2.0dti
When the engine is but I m not driving the heater starts to blow cold air.Even if I have driven the car for good hour or so but when I come to a stop and don't stall the car after 2 min it gets cold I mean heater blowing cold air.
Please advice I have checked the coolant level which is up to the required level
Regards
 

·
Registered
Joined
·
2 Posts
hi your not on your own mate i got a 03 2.0 dti with same problem and when it does go cold rad light comes on occasinally i removed thermostat which sorted it for a week or 2 now back to how it was so if you find out anymore let me know please.
jez
 

·
Registered
Joined
·
2 Posts
ive just found out the reason for the blowing of cold air ive been told it is an air lock in the system so ive spent all day trying to get rid of it will let you knoew if this solves it so all is not lost yet.
jez
 

·
Registered
Joined
·
4 Posts
i have noticed on my di zafira that is very slow to warm up and when it does, the heater is very
poor at full temp on control panel. any idea,s.
 

·
Registered
Joined
·
7 Posts
i have same problem cold heater, slow to warm up and heater blowing luke warmish air only! im thinking water pump not pumping water fast enough around the engine! changed thermostatchanged coolantblead all pipework to the matrixhad matrix flushed out!and still same.on motor way i get just a bit of heat but when come to a stop cold agian! all points to the water pump as the fins tend to fial on zafiras!!
 
1 - 5 of 5 Posts
Top