Vauxhall Zafira Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter · #1 ·
My vans been giving me some grief lately!

My EGR valves been playing up - was intermittently sticking, until one day it was completely stuck open and the car wouldn't start.. AA guy took off my EGR valve cleaned it up and it was working great for a few weeks, then started to get the same symptoms again but not quite as bad..

Decided I would just buy a replacement and fit it my self as it seemed easy enough.

So fitted the new one and the car for the most part has been fine.. however I cant seem to clear the EML light, just keeps coming back on with the same EGR vault code. This seems to be restricting the cars power output as climbing to 60/70 is alot slower..

Error code is Peddle test 40062 or P400/P403 with OBDII

I have a Zafira B 1.7 CDTI (2013)

I don't think the EGR valve I bought was a Genuine GM product was only £70 so probably a China clone! Is that my problem?

Do i need to tell my ECU that i have fitted a new EGR valve? I have seen some mentions of 'retraining' or 'readjustung' the EGR valvue so that the ECU knows its 'ranges'

Can I do this with a cheap OP-COM clone?

Tempted to try and clean up the old original valve and put it back on!

Any help would be appreciated!
 

·
Registered
Joined
·
23 Posts
Discussion Starter · #2 ·
Just had an idea of swapping the electrical solenoid part from the old valve onto the new valve to see if that helps any.. Good new is that its now not showing any falts and the EML has gone out.. bad news is that my coil light is now flashing which I think is for a DPF regen? I guess my cars not been running regen whilst I've had an EGR fault?

Anyway i'll be taking the car out for my 30 mile commute in the morning and will give it a good Italian tuning! Wonder how fast i can go in 3rd :D
 

·
Registered
Joined
·
23 Posts
Discussion Starter · #3 ·
Okay so DPF regen went through, finished half way through my drive! Will have to get OP-COM hooked up to check my sat levels (Never seen the flashing coil lights before because i mostly drive motorway)

Seems 1.7 Zafy has no issues getting to 70mph in 3rd heh

Car seems massively better now EML has gone out, much more acceleration, before I couldn't get past 2k RPM after 4th gear basically speed limited me to 65mph.

I bought a couple cans of wynns egr cleaner which I haven't used yet... going to run one through just as a precaution anyway.. do I spray this in to the air intake before or after the MAF? (the can says it clears air flow sensors, so i was guessing before?)
 

·
Registered
Joined
·
23 Posts
Discussion Starter · #4 ·
Well I managed to sort out the EGR Valve as above.

Having my Timing belt changed tomorrow ~£200

And my gearbox is now making a whining noise which rivals only my kids... Rang a few garages and its going to cost me circa £600.

These vans are expensive to maintain lol!
 

·
Registered
Joined
·
7 Posts
Chriz, i have a zaffy 2014 1.7cdti and i am havibg the same issues as you. I did take off my EGR valve and clean it and considering cleaning the split pipe underneath the EGR valve. Did you ever find out if the ECU needs a reset?, and if so can you do it with Opcom. I am also considering buying a new EGR valve just to try. Also any further advice would be appreciated, thanks Neil
 
1 - 5 of 5 Posts
Top