Vauxhall Zafira Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi to everyone.

We have just bought a Zafira 1.8 elegance x reg 2000.

My wife has been wanting one for a while as we have a young child and one on the way and it fitted our needs perfectly.

The chap we bought it off of seemed very genuine, as it was his wifes car from new. He has had it serviced and had lots of bits done and kept all the reciepts.

Only a few weeks ago he had vauxhall fit a new alternator and we asked him to be totally honest as we havent got a lot of money (who has?) and we really could not afford anymore than we could scrape up for the car.

Only 3 days later a warning light has appeared today, then went off, then appeared again, then on the way home from the Mother in laws it didnt come on at all.

The warning light is the one for the Electronially controlled engine cooling.

As you can probably guess my wife is very upset as she is worried about a hefty repair.

Can anyone shed any light on to what this could be exactly and if it can be fixed by me?
It says it could be the engine cooling system or the cooling circuit for the air con.
Theres plenty of coolant and engine oil.

It was a very hot day and she did have the aircon on. The seller has had the aircon re gassed a few times. I dont know if this could be something to do with it.
Any help would be very much appreciated.

Many thanks

Mart
 

·
Registered
Joined
·
3 Posts
Deart Mart,

I had a similar problem last year. It was due to MKM (Cooling Fan Control Module) problem. Located in left side of Front Bumper. Solved only by "Re-Soldering" some cracked pattern in it's PCB. It was a kind of common problem happened to Zafira in our country. Hopefully help

Thank you and best regards,

Hendro Nurcahyo
Bogor - Indonesia
 

·
Registered
Joined
·
4 Posts
does it have aircon? if it does then try driving it round without using it and see if light still comes on. i have the same light come on on mine and when i dont use the air con it seems to stay off. if it does then your aircon wants looking at
 

·
Registered
Joined
·
3 Posts
Dear Richard,

Yes, It has Aircon.

As far as I remember, The Light didn't on if Aircon off.

best regards,


Hendro. N
 

·
Registered
Joined
·
1 Posts
hi
i had this problem the other day check that both your fans are coming on when you put your air con on i found my front one was not working.you can take out the fan remove the back plate off the motor give it a clean and put back and it might solve the problem.

andy
 
1 - 5 of 5 Posts
Top