Vauxhall Zafira Forum banner

1 - 20 of 21 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Can anybody help me i have a 2000 x reg zafira and i have been experiencing a slight juddering whilst driving. I changed plugs and coil pack and car seemed to drive fine for a week. But now it will drive ok for around 35 - 40 minutes then it starts juddering and when i slow down the engine cuts out, after leaving it a couple of minutes i can start up again and carry on with my journey but after a while it happens again.
Can anyone tell me what the problem could be and how to solve it before i have to spend a fortune in a garage
 

·
Registered
Joined
·
3 Posts
i got a 2003 that had the same thing i thought of fuel blockage but a friend pointed to the EGR valve they are prone to going.hope that helps you
 

·
Registered
Joined
·
2 Posts
We had the same problem on a 52 plate 1.8, after alot of ifs and buts, we ended up taking it to a diagnostics place in Newark, he charged me 30 quid to find out what was wrong, it worked out to be the air mass meter, not saying yours will be as well but well worth finding some where that can do a full check.
He plugged it in and could tell me what was running wrong, touch wood we have had no problems with it since.
Hope this helps
Lee
 

·
Registered
Joined
·
52 Posts
Sounds like it could be the throttle valve stickingespecially if it cuts out when deceleratiing from speed get some throttle body cleaner undo the air inlet circlip on the inlet to the engine lift andpull to one side check to see if it looks oily or dirty.pour or spray some cleanerin wipe away with a clean rag. spray a bit more in and fire up the cleaner should do the trick (it worked great for me). if this doesn't work then it could be the egr valve that needs a clean I have a good web link for both jobs with pics if you need it.
 

·
Registered
Joined
·
68 Posts
HI I WANTED TO CLEAN MY EGR VALVE IF YOU HAVE THE LINK THAT WOULD BE GREAT (NEVERGIVEUP) AS IM HAVING TROUBLE WITH MY ZAFIRA MISFIRING ON CYLINDER 3, IVE HAD IT SERVICED CHANGED COIL PACK AND SPARK PLUGS NO CHANGE.
 

·
Registered
Joined
·
52 Posts
http://zafiradiy.weebly.com/egr.html
The fault code should be 0303 if it's number 3 plug Normally if it's the egr valve it will just cut out when dropping down from speed to traffic lights etc give it a good clean and see if improves it but i suspect it might need a new egr and only buy genuine ones not the cheapo version turn the ignition on and off 30 times leaving a 5 second gap between each go. and it should reset the fault codes. do the pedal trick before you start to check on all stored codes.
 

·
Registered
Joined
·
68 Posts
Yes your right its that fault code 0303 aswell as 0300 which says the same thing cylinder 3 detected misfire, i was changing the coil pack today and took the plugs off to clean them slightly even though ive had a service onThursby vauxhall while i was doing this the 2nd plug from my right hand wasdifferentlooking to the rest, the others were black and the 2nd one looked like it had oil on it and slightly moist but not black, the coil pack never made any change i drove it up the road and back with good revs im scared if i drive it anymore i could damage it even more???? thanks for getting back again.
 

·
Registered
Joined
·
52 Posts
If you have a fault code reader then the multi plug is under the handbrake lever prise out the small plastic cover and it's under that. your reader should be able to reset the eml .If the fault is cleared the management system should clear the fault after 30 stop and starts of the car which is why I said if you switch the ignition on and off 30 times leaving a 5 second delay each time the light should clear (do not start the engine) If you remove the plastic cover on the top of the engine the egr valve is located top right of the engine looking through the wiring loom it is secured with 2 star key bolts and it just lifts away you do not have to remove the wires from it to clean it. if you have not had new plugs I would suggest bosch super plus 4 electrodes mine is a z16 xe and they work really well with this engine
 

·
Registered
Joined
·
68 Posts
ive just seen this, thanks, i have had a service by vauxhall and they replaced the spark plugs but only with gm ones, ive drove the car with high revs the car still issluggish, can i clean it with wd 40 and petrol redex fuel cleaner? i had it on my mates machine and he took the fault off but it only just came back straight away, ive changed the coil pack today but just the same but have not done the ignition on and off 30 times yet so mite give that ago.
 

·
Registered
Joined
·
52 Posts
Iguess you could use wd40 etc but to be honest you can buy egr valve cleaner from Halfords for about a fiver it's much better stuff
you can also blank off the egr valve and get it taken out of the ems so it thinks it's working when it's not betcha an ome EGR valve replacement would solve the problems your having I did it and my car has been fine ever since (well apart from the coil pack knacking up)
 

·
Registered
Joined
·
68 Posts
i did the 30 times waiting inbetween but it never did anything the light just stayed on never went out, i cant even find the egr valve ive had a look at the right hand side under neath the wire bits i can see some bit that has for torx bits on there that seems like it?
 

·
Registered
Joined
·
52 Posts
Yes 2 torque bolts long reach socket set needed hard to see at 1st and a bit fiddly what year is your car as the link I gave you shows the EGR valve in the second picture. By the way I have heard of blocked exhausts giving similar power problemsold one on yours? good luck
 

·
Registered
Joined
·
68 Posts
People!! everyone who messaged and helped, very much appreciated ive had the car in Vauxhall today they done the tech 2 test and the code was just the same 0300 and 0303 which states cylinder 3 misfire, what they did was tried a brand new coil pack on the car and guess what it worked a dream!!I had bought a coil pack on ebay and was told it wasbrand newbut obviously it was faulty!! im so happy tho even tho i paid £229 with military discount still expensive but the jobs done and warranted so happy thank you peeps all the best!! hope this helps someone else.
 

·
Registered
Joined
·
68 Posts
People!! everyone who messaged and helped, very much appreciated ive had the car in Vauxhall today they done the tech 2 test and the code was just the same 0300 and 0303 which states cylinder 3 misfire, what they did was tried a brand new coil pack on the car and guess what it worked a dream!!I had bought a coil pack on ebay and was told it wasbrand newbut obviously it was faulty!! im so happy tho even tho i paid £229 with military discount still expensive but the jobs done and warranted so happy thank you peeps all the best!! hope this helps someone else.
 

·
Registered
Joined
·
52 Posts
Glad you sorted out the problem that's the trouble with Ebay you never can trust aftermarket electronics bitsI bought one lastyear off ebay and it lasted 6 months and put a geniune Delphi coil pack on.
i suspect what you had fitted today was a Delphi coil
 
1 - 20 of 21 Posts
Top