Vauxhall Zafira Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
Hi all

i`v just gone out and brought my first vauxhall it`s a 03 plate zafira 2.0L dti with 62k full history.
i`v had it now for 3 weeks and it been a real pleasure to drive untill today


driving home it all of a suddon started to missfire and the rev`s dropped and cut out, before it cut out there was a light that came up on the dash...outline of a car with a spanner though it...i got it started again and got home but she is very lumpy now and don`t stay started.

is there anyone that can help on this matter please.

Many thanks
 

·
Registered
Joined
·
98 Posts
Arm yourself with some paper, a pen and your car keys. Get in your motor and hold down the brake and accelerator pedals as far as they can go then insert your key and turn the key in the ignition to the 2nd click (last turn before turning on the the engine). Watch the engine management light (EMF). the first four flashes indicatie that its communicating with the ecu, the following flashes mean a fault code. 10 flashes indicate a '0'. the other flashes are genuine and are only separated by a 1 or 2 second gap.

If this fails to work then hold down your settings button when your engine is off. 7 seconds in you should hear a beep. you can then scroll through the diagnostic screen and at the end should be the fault codes if you have any....

Let us know how you get on
 

·
Registered
Joined
·
16 Posts
Discussion Starter #6
right i`v just been outside and tryed this with holding down the 2 pedals the EMF didn`t do nothing didn`t even flash and on the other if i hold down the settings button which i think your talking about the one on the clocks ?? all that says is 044.3 and 24095 not sure how to scroll through it.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #8
right i`v find a new app for my phone where i can plug it into my car...

right its come up with 5 codes
i was wondering if 4 off them are coursed by one thing EGR VALVE.

P0110
P0105
P1222
P0400

The 5th one was the camshaft sensor .... common

also is the egr valve ment to be a sealled unit as it looks like someone has taken it apart.Edited by: baz666
 

·
Registered
Joined
·
98 Posts
What's the phone app called and do you need a specific cable?
 

·
Registered
Joined
·
16 Posts
Discussion Starter #10
The app is called torque but if you have the iphone it`s about£22 to buy for some unknow reason, any other phone ie say the x10 like i have it was about £3 for the whole download.



yes you need a bluetooth obdII plug

check out this first

http://youtu.be/Ay-ZvTn3fLo

got any help on my problem buddy...?

Edited by: baz666
 

·
Registered
Joined
·
18 Posts
Hi according to the book of generic codes

P0110 is IAT Sensor Circuit Malfunction
P0105 is MAP/BARO Circuit Malfunction
P1222 does not exist but P0222 is TPS/Pedal Position Sensor?Switch B Circuit Low Input
P0400 is EGR Flow Malfunction

Might help you but a lot of those are recognised as circuit malfunctions or voltage missing, is your battery healthy and all connectors are fully plugged together?
 

·
Registered
Joined
·
98 Posts
Popeyeman, do you have a good link to these codes. I have some links to codes but clearly there is a published version.Would be good for a sticky if we can get it.

Cheers pal.
 

·
Registered
Joined
·
98 Posts
There's not much holding that together.

I'm afraid i'm not much help as I have a petrol for this very reason. Still it shouldn't do that. Good bit of cleaning and bung it back in. Seems to be what most of the sites are suggesting.

Good luck
 

·
Registered
Joined
·
16 Posts
Discussion Starter #15
£195 i`v just brought a bl***dy new one of ebay, £358.89 for main steelers..

i`m just hoping it sorts the problem out....if not its going.



Edited by: baz666
 
1 - 15 of 15 Posts
Top