Vauxhall Zafira Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hi I have a 1.9cdti Sri zafire 58 plate had issue with turbo a few months ago had a mechanic change it and all was good for a week or 2 then started to get smoke coming from under the bonnet checked and no sign of any problems as soon as I killed the engine smoke stopped started back up and nothing all was fine again until 2 weeks ago it started again had mechanic look he said was the egr cooler pipeas it had a crack so got new one had it fitted but still happened now have smoke and no power as if the turbo has gone again any help would be much appreciated
 

·
Registered
Joined
·
4 Posts
Discussion Starter #2
Started car up no smoke once car headed a little started to get the smoke again from under the bonnet having a look it isn't coming from the egr cooler pipe its coming from front drivers side around the turbo area need help on this guys any ideas?
 

·
Registered
Joined
·
9 Posts
Started car up no smoke once car headed a little started to get the smoke again from under the bonnet having a look it isn't coming from the egr cooler pipe its coming from front drivers side around the turbo area need help on this guys any ideas?
Did you wonder why the turbo failed in the first place? Most probably your cat is fully blocked with soot and that's what caused the turbo to rupture. Now that you've put a healthy turbo in, it's trying to do its job but the pressure is back firing and if it goes on a little longer it will go again and will probably take something with it next time, probably the engine.
Get your exhaust system looked at. That's where I'd go first

Sent from my SM-N9005 using Tapatalk
 
1 - 3 of 3 Posts
Top