Vauxhall Zafira Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
hi new member and had a zaffy for 4 yearsdidn'tknow there was a club so here I am
I have had 1,9 DTI Exclusive 2000 model for last 4 trouble free years and regularly serviced by local garage.
can any one helpweird things happening with my zaffy.
the other day while driving normally I suddenly got the engine cooling light on plus spanner light and lost rev counter, I limped the car home. next day car drove fine for about 5 miles the same thing happened, so got the car home.
Yesterday drove 15 miles no issues car ran fine. this morning car ran fine.
engine will rev freely without a load on and will surge when idling, but loss of power when drivingno loss of coolant, no over heating problem.
HELP
 

·
Registered
Joined
·
4 Posts
Hi I've just found and joined this forum as I have the exact same problem as of today. Can you tell me if you had any replies or if you found out what caused this problem? I have tried the car once cool and the rev counter now works and the car idles normal but I've not been back on the road.

Thanks
Beth
 

·
Registered
Joined
·
4 Posts
I desperately needed my car tomorrow so I studied many many posts on many user groupsinto the night and decided that there was a great chance that the crank sensor was the problem. Today my car was 'fixed'. I bought a Bosch sensor for about £38 and the local garage fitted it.

Neither the pedal check or a diagnostic kit managed to find any code for the problem so we crossed our fingers. I hope this post helps others in the similar position, thanks to all who posted on this in the past. Saved me so much money, time and sanity,
Beth
 
1 - 3 of 3 Posts
Top