Vauxhall Zafira Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Hi all ,new to this forum thing, hope someone can help as my zaf 06 sri 150 cdti is down on power engine management lightis on in dash, not first time aving this prob, main dealer repaired same thing last year on warranty but didnt exactly tell me wot problem was, (was out of action for over a week)as car now out of warranty do i have any comeback if it proved to be same prob



cheers
 

·
Registered
Joined
·
4 Posts
99% sure it'll be a sooted up egr valve. they probo just cleaned it out last time. this time ensure they replace it under warranty. as a short fix try taking it out for a 20 miles motorway thrashing put it in 4th and sit at 70mph. this sometimes forces the car to do a regen which burns of the soot and cleans the valve. sometimes it works for a short time but it will reoccur, im on my 4th egr valve now! sadly vx didn't tell me this car needs to be driven 40k a year and thrashed hard on a weekly basis, not ideal as a family car for 3 kids on mostly school runs then! vx claimed to have introduced a software update and a mod'd valve but i have had 2 mod'd valves and the problem still returns every 6months or so. all the best.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #3
cheers BIGJOCKfor the reply,
as an update the car is running again , dealership didnt want to know and said part only had warranty on orginal warranty. Took it to my local mechanic who said exactly the same as you posted. Find it hard to believe but it worked, he took the valve out, cleaned itand returned it to me to drive for about 15mile 3rd gear high rev. also changed the air filter (which he says should be changed veryregular). Not much good for a car on school run 3 kids, av had loads of probs with this 150cdti.
 

·
Registered
Joined
·
300 Posts
put a blob of paint on egr valve where only you know were it is that way you will tell if it has been changed.
 
1 - 5 of 5 Posts
Top